MySQL backup is not always successful

I put down my code
192.168.0.32 version 5.1
192.168.0.128 version 5.5

The main my.cnf add code
log-bin=/var/log/mysql/updatelog
  server-id = 1
  binlog-do-db=KAPAI
  binlog-ignore-db=mysql

Add the code from my.cnf
server-id=2
log-bin=mysql-bin
master-host=192.168.0.32
master-user=testback
master-password=testback
master-port=3306
replicate-do-db=KAPAI #Need to backup the database name
replicate-ignore-db=mysql #Ignore the database
master-connect-retry=60 #If it is found that the principal server is broken from the server, the re connection of time (seconds)
log-slave-updates #This parameter must be, or not to update records some binary files.
slave-skip-errors #Skip errors, continue to perform a copy operation


Error performance:
slave stop

mysql> CHANGE MASTER TO MASTER_HOST='192.168.0.32',MASTER_USER='testback',MASTER_PASSWORD='testback',MASTER_LOG_FILE='log-bin.000018',MASTER_LOG_POS=106;
Query OK, 0 rows affected (0.10 sec)

mysql> slave start;
ERROR 1200 (HY000): The server is not configured as slave; fix in config file or with CHANGE MASTER TO
mysql> show slave status\G
*************************** 1. row ***************************
Slave_IO_State:
Master_Host: 192.168.0.32
Master_User: testback
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: log-bin.000018
Read_Master_Log_Pos: 106
Relay_Log_File: mysqld-relay-bin.000001
Relay_Log_Pos: 4
Relay_Master_Log_File: log-bin.000018
Slave_IO_Running: No
Slave_SQL_Running: No
Replicate_Do_DB:
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 106
Relay_Log_Space: 106
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: NULL
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 1045
Last_IO_Error: error connecting to master 'testsback@192.168.0.32:3306' - retry-time: 60 retries: 86400
Last_SQL_Errno: 0
Last_SQL_Error:


Pray God see the Internet search is said to add CHANGE MASTER TO MASTER_HOST='192.168.0.32', MASTER_USER='testback', MASTER_PASSWORD='testback', MASTER_LOG_FILE='log-bin.000018', MASTER_LOG_POS=106; this but I have added countless times

I saw error connecting to master'testsback@192.168.0.32:3306'Last_IO_Error: retry-time: 60 retries: 86400 the error that is not on the connection problem? ?
But I also use this account telnet master library

Started by Ian at November 28, 2016 - 6:03 PM

To top it. Don't sink.

Posted by Ian at December 03, 2016 - 6:40 PM

To top it. Don't sink.

Posted by Ian at December 15, 2016 - 7:09 PM

To top it. Don't sink.

Posted by Ian at December 27, 2016 - 8:05 PM