Rails error, help seeking, urgent urgent!!

I installed rubyMine, create a new railsApplication, report such a mistake:
F:\Ruby\ruby\rubyIntall\install\Ruby193\bin\rake
[align=center][rake --tasks] rake aborted!
Could not find gem 'turn (~> 0.8.3) x86-mingw32' in any of the gem sources listed in your Gemfile.
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/resolver.rb:280:in `resolve'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/resolver.rb:160:in `start'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/resolver.rb:128:in `block in resolve'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/resolver.rb:127:in `catch'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/resolver.rb:127:in `resolve'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/definition.rb:151:in `resolve'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/definition.rb:90:in `specs'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/definition.rb:135:in `specs_for'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/definition.rb:124:in `requested_specs'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/environment.rb:23:in `requested_specs'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime.rb:11:in `setup'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler.rb:110:in `setup'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/setup.rb:17:in `<top (required)>'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in `require'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in require'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
F:/Ruby/rubyMine_workspace/rubyMine_workspace/config/boot.rb:6:in `<top (required)>'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
F:/Ruby/rubyMine_workspace/rubyMine_workspace/config/application.rb:1:in `<top (required)>'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
F:/Ruby/rubyMine_workspace/rubyMine_workspace/Rakefile:5:in `<top (required)>'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/rake_module.rb:25:in `load'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/rake_module.rb:25:in `load_rakefile'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:501:in `raw_load_rakefile'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:82:in `block in load_rakefile'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:133:in `standard_exception_handling'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:81:in `load_rakefile'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:65:in `block in run'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:133:in `standard_exception_handling'
F:/Ruby/ruby/rubyIntall/install/Ruby193/lib/ruby/1.9.1/rake/application.rb:63:in `run'
F:/Ruby/ruby/rubyIntall/install/Ruby193/bin/rake:32:in `<main[/align]>'

Ruby support is my own to download and install the following path, F:\Ruby\ruby\rubyIntall\install\Ruby193\...

I guess the reason, we do not know is what opinion?? Also, I netBeans to create railsApplication will also report such errors

Started by Kenny at November 09, 2016 - 4:25 AM

I also had this error.
Open a command line window, execute bundle install

Is expected to do plug-ins caused. I am so resolved,

Posted by Aaron at November 15, 2016 - 4:50 AM

It CD the execution of the works.


E:\ruby\project\depot>bundle install
Using rake (0.9.2.2)
Using multi_json (1.0.3)
Using activesupport (3.1.1)
Using builder (3.0.0)
Using i18n (0.6.0)
Using activemodel (3.1.1)
Using erubis (2.7.0)
Using rack (1.3.5)
Using rack-cache (1.1)
Using rack-mount (0.8.3)
Using rack-test (0.6.1)
Using hike (1.2.1)
Using tilt (1.3.3)
Using sprockets (2.0.3)
Using actionpack (3.1.1)
Using mime-types (1.17.2)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.3.0)
Using actionmailer (3.1.1)
Using arel (2.2.1)
Using tzinfo (0.3.31)
Using activerecord (3.1.1)
Using activeresource (3.1.1)
Using ansi (1.4.1)
Using bundler (1.0.21)
Using coffee-script-source (1.1.3)
Using execjs (1.2.9)
Using coffee-script (2.2.0)
Using rack-ssl (1.3.2)
Using json (1.6.1)
Using rdoc (3.11)
Using thor (0.14.6)
Using railties (3.1.1)
Using coffee-rails (3.1.1)
Using jquery-rails (1.0.18)
Using rails (3.1.1)
Using sass (3.1.10)
Using sass-rails (3.1.5)
Using sqlite3 (1.3.4)
Using turn (0.8.3)
Using uglifier (1.1.0)
Using will_paginate (3.0.2)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem
is installed.

E:\ruby\project\depot>

Posted by Aaron at November 24, 2016 - 5:33 AM

Upstairs in the NetBeans IDE.?

Posted by Kenny at December 03, 2016 - 6:15 AM

It still doesn't work, execute bundle install to the end surface error, I was at the end of a using... Out after a installing JSON... And then said error

Posted by Kenny at December 14, 2016 - 6:31 AM

Rubymine ah. That you did not install the JSON plugin, gem install json. Try it

Posted by Aaron at December 26, 2016 - 6:33 AM

The newspaper is wrong, wrong is as follows:
ERROR:Error installing json:
The "json" native gem requires installed build tools.
Please update your PATH to include build tools or download the DevKit from 'http://rubyinstaller.org/downloads' and follow the instructions at 'http://github.com/oneclick/rubyinstaller /wiki/Development-Kit'

My environment variables have with good ah, ruby -v and rails V can be normal operating results

Posted by Kenny at January 04, 2017 - 8:33 AM

Do not install the gem environment.
The simplest way to unload from loading, installation, inside installation package.

Posted by Aaron at January 08, 2017 - 7:04 AM

Thanks. . .

Posted by Kenny at January 12, 2017 - 9:19 AM

Change the GemFile

Posted by Anastasia at January 13, 2017 - 7:48 AM