MyEclipse2014 added bug, should pay attention to the early adopters of the frien

Recommended for you: Get network issues from WhatsUp Gold. Not end users.

Before being used MyEclipse8.5, MyEclipse9.1, MyEclipse10.5 development WEB project, recently heard that the latest version is called MyEclipse2014, and decided to taste fresh, running a previously written under the MyEclipse10.5 project, was wrong:

Error configuring application listener of: class org.springframework.web.context.ContextLoaderListener

java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1328)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1175)
at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:549)
at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:530)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:150)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4653)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5159)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:726)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:702)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:697)
at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1134)
at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1780)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:744)


Began to check the Jar package, check the configuration file, check Tomcat, determine what problem did not!

And then, Redeploy Clean also does not work!

Online search, nor what the correct solution!

Depressed, depressed, feel helpless when, think of a previous bug:jar when using the Eclipse package can only be placed in the Lib directory, directory cannot separate! (this is my don't like with Eclipse one of the reasons)

Try to make my jar packet is copied to the lib and below, start, and work!!!

Fuck. How more upgrade more backwards!!!

Get for a long time, he gave me a surprise this ""!

Fucking MyEclipse2014 bug, early adopters friends need to be cautious!

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download

Posted by Edwin at June 05, 2014 - 12:26 AM