Two integrated configuration example of PIM multicast network

Recommended for you: Get network issues from WhatsUp Gold. Not end users.

The following is an excerpt from being dangdang.com, 360buy, Joyo, interactive publishing network sale, will be formally released "Huawei switch study guide" one book (Book of nearly a thousand pages). This book is authorized by the Huawei official, the first in the country, and only a Huawei switch authoritative study guide, is Huawei ICT certification training specified materials.

Dangdang.com link: Jingdong network links:

Superior online links: (31% off in limited time Fengqiang)
Interactive Publishing Web links:

Subscription book, see the lottery (cash, Book Awards waiting for you),

Click here to view the details: http://blog.chinaunix.net/uid-10659021-id-3992864.html

Along with the popularization of Internet application, IP multicast has been widely used in the remote video conference, remote medical applications. In most enterprises IP multicast network is generally just run the PIM protocol and IGMP protocol, the former for router (also can be the three layer switch) connections, which is used for connecting the multicast and multicast users, of course, at the edge of the network IGMP protocol router also need to run PIM protocol at the same time, to make it easier for other PIM multicast routing router. In PIM protocol, the most typical is ASM and SSM the twoThe model will be introduced in this paper, Huawei S series switchesTwo based on the specific configuration of the ideas and methods of IP multicast network of these two kinds of PIM models.

13.3.6 PIM-SM (ASM model) comprehensive configuration example

This example topology structure as shown in figure 13-8, is a single domain PIM-SM network. The user host HostA, HostB hopes to receive multicast data transmission Source.

The sample PIM-SM domain 13-8 model of ASM multicast configuration

1.       Analysis of the basic configuration idea

This example does not explicitly require the user to specify only sent to the multicast source data, so it can be achieved by using PIM-SM ASM model, the add all the user host the same multicast group can receive any source to multicast data in the group. Overall configuration tasks are as follows (mainly the basic function of the PIM-SM ASM configuration):

(1)Configure the switch of the VLAN interface IP address and unicast routing protocol. Multicast routing protocol PIM relies on unicast routing protocol, multicast protocol unicast routing normal is the foundation work.

(2)In all provide multicast service switches enable multicast routing functions, is a prerequisite for configuring PIM-SM.

(3)On the switch on all interfaces enable PIM-SM function, and then the other function to configure PIM-SM.

(4)Switch interface is connected with the host side in IGMP to enable. Multicast group members can leave a multicast group by sending a IGMP message freely join or. Leaf node switches through the IGMP protocol to maintain the group membership list.

If the user host side and configuration of PIM-SM and IGMP, you must first enable PIM-SM, then enable IGMP.

(5)Switch interface can be connected with the host side of the PIM Silent, to prevent the malicious host sending PIM Hello message, and increase the security of PIM-SM domain. But if the user host (such as HostB) where the network segment with multiple switches, then the user host side interface not these switches to enable PIM Silent, such as the corresponding interface graph SwitchB, SwitchC.

(6)The configuration of RP. In the PIM-SM field, RP is the core to provide ASM services, is to transfer multicast data forwarding station. Position RP configuration in the multicast traffic branching switch, as shown in the SwitchE position.

(7)Configure the BSR boundary in the SwitchD GE0/0/1 interface and are connected with the bootstrap message, not through the boundary, the BSR to the PIM-SM domain services, increase multicast controllability.

2 specific configuration steps

The following are the specific configuration steps above each configuration tasks.

(1)According to mark the VLAN switch interface configuration of IP address and mask, configure the switch between using OSPF interconnection, to ensure that the switch in network to network layer interconnection. Because the configuration method of SwitchA, SwitchB, SwitchC, SwitchD and SwitchE, so now take SwitchA as example to introduce the configuration.

[SwitchA] vlan batch 10 20 30 #- batch create VLAN 10, VLAN 20 and VLAN 30

[SwitchA] interface gigabitethernet0/0/1

[SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10

[SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface gigabitethernet0/0/2

[SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 20

[SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 20

[SwitchA-GigabitEthernet0/0/2] quit

[SwitchA] interface gigabitethernet0/0/3

[SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 30

[SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 30

[SwitchA-GigabitEthernet0/0/3] quit

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 192.168.5.1 24

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] ip address 10.110.1.1 24

[SwitchA-Vlanif20] quit

[SwitchA] interface vlanif 30

[SwitchA-Vlanif30] ip address 192.168.1.1 24

[SwitchA-Vlanif30] quit

[SwitchA] ospf

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] quit

(2)In all switch enable multicast routing function, in the VLAN interface enables the PIM-SM function. Also because the configuration method of SwitchA, SwitchB, SwitchC, SwitchD and SwitchE, so only in the case of the SwitchA are introduced.

[SwitchA] multicast routing-enable

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] pim sm

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] pim sm

[SwitchA-Vlanif20] quit

[SwitchA] interface vlanif 30

[SwitchA-Vlanif30] pim sm

[SwitchA-Vlanif30] quit

(3)Connect the user host in the SwitchA interfaces to enable IGMP function. The configuration process with SwitchA SwitchB and SwitchC on the similar configuration, configuration process slightly.

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] igmp enable

(4)In the SwitchA interface enables the PIM silent.

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] pim silent

(5)The configuration of RP. The configuration of RP in two ways: static RP and dynamic RP two. You can also configure, can also configured with only one. At the same time two RP, can be adjusted through the parameters choose what kind of RP. This example also configuration of two kinds of RP, the default optimization dynamic RP, static RP as backup.

Below is the configuration method of dynamic RP, will require one or more switches PIM-SM domain is configured for C-RP and C-BSR. This example specifies SwitchE for both the C-RP and C-BSR, group address range to configure the RP service on the SwitchE, and C-BSR and C-RP where the interface position.

[SwitchE] acl number 2008

[SwitchE-acl-basic-2008] rule permit source 225.1.1.0 0.0.0.255

[SwitchE-acl-basic-2008] quit

[SwitchE] pim

[SwitchE-pim] c-bsr vlanif 60

[SwitchE-pim] c-rp vlanif 60 group-policy 2008

Here is a static RP, need to specify a static RP address on all switches in the. Because the configuration method of SwitchA, SwitchB, SwitchC, SwitchD and SwitchE, now take SwitchA as example to introduce the configuration.

[SwitchA] pim

[SwitchA-pim] static-rp 192.168.2.2

(6)With SwitchD and domain configuration on the interface of BSR boundary.

[SwitchD] interface vlanif 70

[SwitchD-Vlanif70] pim bsr-boundary

[SwitchD-Vlanif70] quit

Configuration, thedisplay pim interfaceCommand interface PIM configuration and operation, to verify the configuration result. SwitchC PIM display information as follows:

<SwitchC> display pim interface

VPN-Instance: public net

Interface      State   NbrCnt   HelloInt   DR-Pri     DR-Address

Vlanif40        up      0         30         1         10.110.2.2    (local)

Vlanif50        up      1         30         1         192.168.3.1   (local)

Throughdisplay pim bsr-infoCommand switch BSR election information. SwitchA and SwitchE BSR information are as follows (SwitchE also display C-BSR information):

<SwitchA> display pim bsr-info

VPN-Instance: public net

 Elected AdminScoped BSR Count: 0

 Elected BSR Address: 192.168.4.2

     Priority: 0

     Hash mask length: 30

     State: Accept Preferred

     Scope: Not scoped

     Uptime: 01:40:40

     Expires: 00:01:42

     C-RP Count: 1

 

<SwitchE> display pim bsr-info

VPN-Instance: public net

 Elected AdminScoped BSR Count: 0

 Elected BSR Address: 192.168.4.2

     Priority: 0

     Hash Mask length: 30

     State: Elected

     Scope: Not scoped

     Uptime: 00:00:18

     Next BSR message scheduled at :00:01:42

     C-RP Count: 1

 Candidate AdminScoped BSR Count: 0

 Candidate BSR Address: 192.168.4.2

     Priority: 0

     Hash mask length: 30

     State:Elected

     Scope: Not scoped  

     Wait to be BSR: 0

Throughdisplay pim rp-infoGet command to view the Switch RP information. RP information on the SwitchA.:

<SwitchA> display pim rp-info

VPN-Instance: public net

 PIM-SM BSR RP Number:1

 Group/MaskLen: 225.1.1.0/24

     RP: 192.168.4.2

     Priority: 0

     Uptime: 00:45:13

     Expires: 00:02:17

 PIM SM static RP Number:1

     Static RP: 192.168.2.2  

Throughdisplay pim routing-tableCommand for the PIM protocol multicast routing table. Multicast source (10.110.3.100/24) to the multicast group (225.1.1.1/24) to send information, HostA, HostB have joined the multicast group (225.1.1.1/24). PIM multicast routing tables SwitchA and SwitchB display as follows, the other switch multicast routing table shows similar.

[Description] by default, the members of DR will trigger the SPT switch in the terminal receiving the first multicast data multicast source sends in, a new (S, G) routing table. Therefore the switch display (S, G) routing table entries are generally SPT after switch (S, G) routing table.

[SwitchA] display pim routing-table

VPN-Instance: public net

 Total 1 (*, G) entry; 1 (S, G) entry

 

(*, 225.1.1.1)

     RP: 192.168.4.2

     Protocol: pim-sm, Flag: WC

     UpTime: 00:13:46

     Upstream interface: Vlanif10,

         Upstream neighbor: 192.168.5.2

         RPF prime neighbor: 192.168.5.2

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif20

             Protocol: pim-sm, UpTime: 00:13:46, Expires:-

 

(10.110.3.100, 225.1.1.1)

     RP: 192.168.4.2

     Protocol: pim-sm, Flag: SPT ACT

     UpTime: 00:00:42

     Upstream interface: Vlanif30

         Upstream neighbor: 192.168.1.2

         RPF prime neighbor: 192.168.1.2

    Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif20

             Protocol: pim-sm, UpTime: 00:00:42, Expires:-

[SwitchB] display pim routing-table

VPN-Instance: public net

 Total 1 (*, G) entry; 1 (S, G) entry

 

(*, 225.1.1.1)

     RP: 192.168.4.2

     Protocol: pim-sm, Flag: WC

     UpTime: 00:10:12

     Upstream interface: Vlanif90,

         Upstream neighbor: 192.168.2.2

         RPF prime neighbor: 192.168.2.2

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif40

             Protocol: pim-sm, UpTime: 00:10:12, Expires:-

 

(10.110.3.100, 225.1.1.1)

     RP: 192.168.4.2

     Protocol: pim-sm, Flag: SPT ACT

     UpTime: 00:00:42

     Upstream interface: Vlanif90

         Upstream neighbor: 192.168.2.2

         RPF prime neighbor: 192.168.2.2

    Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif40

             Protocol: pim-sm, UpTime: 00:00:30, Expires:-

13.3.7 PIM-SM (SSM model) comprehensive configuration example

This example topology structure as shown in figure 13-9, is a single domain PIM-SM network. The HostA hopes to receive the multicast source S1 (10.110.4.100/24), S2 (10.110.3.100/24) multicast data transmission, and HostB hopes to receive the multicast source multicast data transmission S2.

Analysis of 1 basic ideas

This example requires multicast group members specify only the multicast data source receives, therefore needs to use the PIM-SM SSM model, so that the user host to join a multicast group and receive the multicast data source specified multicast oneself of.

Compared with the PIM-SM ASM model, SSM model configuration is much simpler, because it is not required for the maintenance of RP, also do not need special construction of SPT, also no need to register the multicast source, only need to enable the SSM service configuration, designated to receive multicast source data used to define the group policy. The following is the basic configuration tasks in this example:

PIM-SM domain 13-9 model of SSM multicast topology configuration example

(1)Configure the switch interface IP address and unicast routing protocol.

(2)In all provide multicast service switches enable multicast function.

(3)On the switch on all interfaces enable PIM-SM function.

(4)Switch interface is connected with the host side of the IGMP, version number and configuration of IGMP protocol for V3, because SSM is not enabled in case of Mapping IGMPv3 only supports the SSM service.

If the user host side and configuration of PIM-SM and IGMP, you must first enable PIM-SM, then enable IGMP.

(5)Switch interface is connected with the host side of the PIM Silent, to prevent the malicious host sending PIM Hello message, and increase the security of PIM-SM domain. Similarly, if the user host network segment with multiple switches, then the user host side interface not these switches to enable PIM Silent, as shown in figure SwitchB, SwitchC.

(6)Set the SSM address in the range of each switch group. The PIM-SM domain switches for the specific group address within the scope of the SSM service, realize the controllable multicast. But the switch settings group SSM address range must be the same.

(7)Configure the Join-Prune packet filtering the VLANIF switch interface connected to the HostA and HostB host, in order to achieve only limited to receive multicast data from the multicast source.

2 specific configuration steps

The following are the specific configuration steps in this example.

(1)According to the diagram in 13-9 tagging each switch VLAN interface IP address and mask, configure the switch between using OSPF interconnection, to ensure that the switch in network to network layer interconnection. Because the configuration method of SwitchA, SwitchB, SwitchC, SwitchD, SwitchE and SwitchF, so only in the case of the SwitchA are introduced.

[SwitchA] vlan batch 10 20 30

[SwitchA] interface gigabitethernet0/0/1

[SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 10

[SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 10

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface gigabitethernet0/0/2

[SwitchA-GigabitEthernet0/0/2] port hybrid pvid vlan 20

[SwitchA-GigabitEthernet0/0/2] port hybrid untagged vlan 20

[SwitchA-GigabitEthernet0/0/2] quit

[SwitchA] interface gigabitethernet0/0/3

[SwitchA-GigabitEthernet0/0/3] port hybrid pvid vlan 30

[SwitchA-GigabitEthernet0/0/3] port hybrid untagged vlan 30

[SwitchA-GigabitEthernet0/0/3] quit

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] ip address 192.168.5.1 24

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] ip address 10.110.1.1 24

[SwitchA-Vlanif20] quit

[SwitchA] interface vlanif 30

[SwitchA-Vlanif30] ip address 192.168.1.1 24

[SwitchA-Vlanif30] quit

[SwitchA] ospf

[SwitchA-ospf-1] area 0

[SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255

[SwitchA-ospf-1-area-0.0.0.0] quit

[SwitchA-ospf-1] quit

(2)In all switch enable multicast routing function, in the VLAN interface enables the PIM-SM function. Also because the configuration method of SwitchA, SwitchB, SwitchC, SwitchD, SwitchE and SwitchF, so the following is only in the case of the SwitchA are introduced.

[SwitchA] multicast routing-enable

[SwitchA] interface vlanif 10

[SwitchA-Vlanif10] pim sm

[SwitchA-Vlanif10] quit

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] pim sm

[SwitchA-Vlanif20] quit

[SwitchA] interface vlanif 30

[SwitchA-Vlanif30] pim sm

[SwitchA-Vlanif30] quit

(3)Connect the user host in the SwitchA interfaces to enable IGMPv3 function. The configuration process with SwitchA SwitchB and SwitchC on the similar configuration, configuration process slightly.

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] igmp enable

[SwitchA-Vlanif20] igmp version 3

(4)In the SwitchA interface enables the PIM silent.

[SwitchA] interface vlanif 20

[SwitchA-Vlanif20] pim silent

(5)In all switch configuration SSM multicast group address range 232.1.1.0/24. Because the configuration method of SwitchA, SwitchB, SwitchC, SwitchD, SwitchE and SwitchF, so only in the case of the SwitchA are introduced.

[SwitchA] acl number 2000

[SwitchA-acl-basic-2000] rule permit source 232.1.1.0 0.0.0.255 #Confined multicast message 232.1.1.0/24 range by

[SwitchA-acl-basic-2000] quit

[SwitchA] pim

[SwitchA-pim] ssm-policy 2000

(6)Configure the Join-Prune packet filtering on the VLANIF20 interface of SwitchA, specify HostA to receive the multicast multicast data sent to the source S1 and S2.

[SwitchA-pim] quit

[SwitchA] acl number 3001

[SwitchA-acl-adv-3001] rule permit source 10.110.3.100 0 destination 232.1.1.0 0.0.255.255

[SwitchA-acl-adv-3001] rule permit source 10.110.4.100 0 destination 232.1.1.0 0.0.255.255

[SwitchA-acl-adv-3001]quit

[SwitchA] interface vlanif 20

[SwitchA –Vlanif20] pim join-policy asm 3001

(7)Configure the Join-Prune packet filtering on the VLANIF40 interface of SwitchB and SwitchC, designated HostB can only receive the multicast multicast data source S2. For SwitchB and SwitchC, in which only the SwitchB configuration as example to introduce.

[SwitchB] acl number 3001

[SwitchB-acl-adv-3001] rule permit source 10.110.3.100 0 destination 232.1.1.0 0.0.255.255

[SwitchB-acl-adv-3001]quit

[SwitchB] interface vlanif 40

[SwitchB –Vlanif40] pim join-policy asm 3001

Configuration, thedisplay pim interfaceCommand interface PIM configuration and operation, to verify the configuration result. SwitchC PIM display information as follows:

<SwitchC> display pim interface

VPN-Instance: public net

Interface      State   NbrCnt   HelloInt   DR-Pri     DR-Address

Vlanif40        up      0         30         1         10.110.2.2    (local)

Vlanif50        up      1         30         1         192.168.3.1   (local)

Throughdisplay pim routing-tableCommand for the PIM protocol multicast routing table. SwitchA and SwitchB display information as follows. It can be seen from the HostA receives a multicast source (10.110.3.100/24) and multicast source (10.110.4.100/24) sent to the multicast group (232.1.1.1/24) information, HostB only receives the multicast source (10.110.3.100/24) sent to the multicast group (232.1.1.1/24) information, meet the requirements.

[SwitchA] display pim routing-table

 VPN-Instance: public net

 Total 2 (S, G) entry

 

(10.110.3.100, 232.1.1.1)

     Protocol: pim-ssm, Flag: SG_RCVCR

     UpTime: 00:13:46

     Upstream interface: Vlanif10,

         Upstream neighbor: 192.168.5.2

         RPF prime neighbor: 192.168.5.2

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif20

             Protocol: pim-ssm, UpTime: 00:13:46, Expires:-

 

(10.110.4.100, 232.1.1.1)

     Protocol: pim-ssm, Flag: SG_RCVCR

     UpTime: 00:00:42

     Upstream interface: Vlanif30

         Upstream neighbor: 192.168.1.2

         RPF prime neighbor: 192.168.1.2

    Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif20

             Protocol: pim-ssm, UpTime: 00:00:42, Expires:-

[SwitchB] display pim routing-table

 VPN-Instance: public net

 Total 1 (S, G) entry

 

(10.110.3.100, 232.1.1.1)

     Protocol: pim-ssm, Flag: SG_RCVCR

     UpTime: 00:10:12

     Upstream interface: Vlanif90,

         Upstream neighbor: 192.168.2.2

         RPF prime neighbor: 192.168.2.2

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlanif40

             Protocol: pim-ssm, UpTime: 00:10:12, Expires:-

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download

Posted by Stacy at December 10, 2013 - 11:31 AM